Project

General

Profile

Bug #393

batadv-vis: dmesg deprecation warnings

Added by Linus Lüssing over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
06/19/2019
Due date:
% Done:

0%

Estimated time:

Description

Every UPDATE_INTERVAL (10 seconds) batadv-vis creates a warning like the following for each interface:

[  775.385966] batman_adv: [Deprecated]: batadv-vis (pid 3251) Use of sysfs file "iface_status".
[  775.385966] Use batadv genl family instead
[  785.389259] batman_adv: [Deprecated]: batadv-vis (pid 3251) Use of sysfs file "mesh_iface".
[  785.389259] Use batadv genl family instead

It seems that register_interfaces() in vis.c was not updated to use netlink to query "iface_status" and "mesh_iface" yet.

The issue is present when using batman-adv v2019.2.

History

#1

Updated by Sven Eckelmann over 1 year ago

Following two commits from batctl have to be (adjusted and) imported:

  • ef66312939e6 ("batctl: Add netlink fallback for sysfs' iface_status")
  • 07967cd19702 ("batctl: Support checking of meshif without sysfs")
#2

Updated by Sven Eckelmann over 1 year ago

  • Target version set to 2019.3
  • Assignee changed from batman-adv developers to Linus Lüssing
  • Status changed from New to Resolved
#3

Updated by Sven Eckelmann over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF