Project

General

Profile

Bug #253

How to use Batman-adv api in developing a simple application

Added by Sharath R V about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Target version:
-
Start date:
06/01/2016
Due date:
% Done:

0%

Estimated time:

Description

So i just started using batman-adv. I wish to know if anyone can point me to some sample code where batman-adv APIs are used to develop an application. For example, how would i use batman-adv api to do file transfer between two devices connected over batman-adv mesh.

History

#1

Updated by Sven Eckelmann about 4 years ago

  • Status changed from New to Rejected

batman-adv is just an extra layer between the real link layer and the transport layer. So it behaves like a distributed ethernet switch.

There is no special API which you use for batman-adv data transfers. Just the normal network stack and sockets. Applications usually don't know that they send data over batman-adv. They also usually don't know that they send data over wifi or over ethernet or something else.

Btw. this is not a bug. So you filled it incorrectly in the issue tracker.

Also available in: Atom PDF