Project

General

Profile

Bug #194

multicast_mode appears to block avahi traffic

Added by Bill Richardson about 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
09/11/2014
Due date:
% Done:

0%

Estimated time:

Description

Not sure if this is a batman-adv issue or a kernel, avahi, or openwrt issue...

I've been running OpenWrt r40555 on a handful of ar71xx routers all connected with batman-adv. Avahi has been working great across the mesh, until I updated the firmware on the routers to Barrier-Breaker 14.07.rc2 (r42087). Everything works as expected, except for the forwarding of avahi packets. Avahi now works within the space of a single router but not across the batman-adv mesh.

Batman-adv on the latest rev of OpenWrt has been updated to 2014.2.0 and introduces "multicast_mode" for the first time on OpenWrt. When I disable multicast_mode in batman-adv, my avahi traffic across the mesh works again. With the new multicast_mode enabled (batman-adv's default), avahi does not work across the mesh. It looks as though multicast_mode is blocking the receipt of mdns responses, not the sending of mdns queries.

History

#1

Updated by Marek Lindner over 6 years ago

  • Assignee set to Linus Lüssing

Linus (the author of the multicast optimizations) suggested upgrading to 2014.4.0. Your problem seems to be known and fixed.

#2

Updated by Linus Lüssing over 6 years ago

Like Marek said, please upgrade to 2014.4.0 and let us know whether that helps. For instance just copy the feeds.conf.default to feeds.conf and remove the ";for-14.07" in the line for the routing feed in a recent barrier breaker.

Sorry for replying so late, must have missed this ticket back then.

#3

Updated by Marek Lindner over 6 years ago

Could we get an update on whether or not the issue is still existing ? If not, we'd like to close this ticket.

#4

Updated by Bill Richardson over 6 years ago

Thanks, I'll try it out when i get a a chance and report back.

#5

Updated by Marek Lindner over 6 years ago

Any update ?

#6

Updated by Bill Richardson over 6 years ago

Yes, I do believe it is working now.

Following your instructions above, I have the following.

Barrier Breaker r44952
batman-adv 2014.4.0
batman-adv multicast_mode enabled
avahi-daemon 0.6.31
WNDR3700v4

mdns is crossing the batman-adv mesh with multicast_mode enabled, as expected. Looking forward to experimenting with the optimizations. Thanks Marek Lindner and @Linus!

#7

Updated by Marek Lindner over 6 years ago

  • Status changed from New to Closed

Thanks for checking!

#8

Updated by Sven Eckelmann over 4 years ago

  • Target version set to 2014.4.0

Also available in: Atom PDF