Project

General

Profile

Bug #166

"INFO: possible recursive locking detected" (batadv_tt_global_del_orig vs. batadv_orig_node_free_ref)

Added by Linus Lüssing almost 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
11/08/2012
Due date:
% Done:

100%

Estimated time:

Description

When deleting the wifi interface currently used by batman-adv with i.e. 'iw dev wlan0-1 del' on an Alix board with an ath9k based wifi card with a recent OpenWRT version from the Attitude Adjustment branch (rev. 34092, Linux 3.3.8) plus vanilla batman-adv 2012.4.0 as well as some extra kernel debugging options, I'm getting the following recursive locking warning:

[...]
[   71.893406] =============================================
[   71.896725] [ INFO: possible recursive locking detected ]
[   71.896725] 3.3.8 #14 Tainted: G           O
[   71.896725] ---------------------------------------------
[   71.896725] iw/1789 is trying to acquire lock:
[   71.896725]  (&(&hash->list_locks[i])->rlock){+.-...}, at: [<d0fc541e>] batadv_tt_global_del_orig+0x4e/0xf0 [batman_adv]
[   71.896725]  
[   71.896725] but task is already holding lock:
[   71.896725]  (&(&hash->list_locks[i])->rlock){+.-...}, at: [<d0fbe0ee>] batadv_orig_node_free_ref+0x7e/0x340 [batman_adv]
[...]

See attached dmesg output for the complete trace.


Files

batman-adv-recursive-locking.dmesg (27 KB) batman-adv-recursive-locking.dmesg Linus Lüssing, 11/08/2012 08:54 AM

History

#1

Updated by Antonio Quartulli almost 8 years ago

  • Assignee set to Antonio Quartulli
  • Status changed from New to In Progress

Linus, thanks for reporting!
This is probably a false positive triggered by lockdep. I will post a patch soon.

#2

Updated by Antonio Quartulli almost 8 years ago

  • % Done changed from 0 to 50

Hi Linus, can you try this and see if it solves?
https://patchwork.open-mesh.org/project/b.a.t.m.a.n./patch/1352541632-25336-1-git-send-email-ordex@autistici.org/
Even if I don't know whether it is easy for you to reproduce the problem.
Thanks!

#3

Updated by Linus Lüssing almost 8 years ago

Antonio Quartulli wrote:

Hi Linus, can you try this and see if it solves?
https://patchwork.open-mesh.org/project/b.a.t.m.a.n./patch/1352541632-25336-1-git-send-email-ordex@autistici.org/
Even if I don't know whether it is easy for you to reproduce the problem.
Thanks!

Yes, both the issue is easily reproduceable and the suggested patch seems to get rid of it, just tested it.

Thank you, too!

#4

Updated by Antonio Quartulli almost 8 years ago

  • % Done changed from 50 to 100
  • Status changed from In Progress to Resolved
#5

Updated by Antonio Quartulli about 7 years ago

  • Status changed from Resolved to Closed
#6

Updated by Sven Eckelmann over 3 years ago

  • Target version set to 2013.1.0

Also available in: Atom PDF