Project

General

Profile

Bug #130

batman-adv lock-up

Added by Simon Wunderlich almost 12 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Marek found this bug while testing:

BUG: spinlock lockup on CPU#0, bat_events/516, c0200280 
Call Trace: 
[<80048f34>] dump_stack+0x8/0x34 
[<80154700>] _raw_spin_lock+0x104/0x12c 
[<80223350>] _spin_lock+0x64/0x80 
[<c01f4420>] purge_orig+0x30/0x2f4 [batman_adv] 
[<80078098>] run_workqueue+0x170/0x270 
[<80078e48>] worker_thread+0xac/0xd4 
[<8007c918>] kthread+0x58/0xa0 
[<800455d4>] kernel_thread_helper+0x10/0x18

this seems to be present in r1397. It rarely occurs ~1 second after loading the module.

Seems the spinlock is held elsewhere.

Another similar occurence has been found here:

BUG: spinlock lockup on CPU#0, bat_events/1346, c01ea280
Call Trace:
[<80048f34>] dump_stack+0x8/0x34
[<80154d20>] _raw_spin_lock+0x104/0x12c
[<80223970>] _spin_lock+0x64/0x80
[<c01e1fa0>] purge_vis_packets+0x138/0x83c [batman_adv]

History

#1

Updated by Marek Lindner almost 12 years ago

  • Status changed from New to In Progress

How to reproduce the problem:

i=0; while [ 1 ]; do i=@expr $i + 1@; echo "run $i" > /dev/console; insmod batman-adv; batctl if mesh0; sleep 5; rmmod batman-adv; done
#2

Updated by Marek Lindner almost 12 years ago

  • Status changed from In Progress to Closed

Just tested again with revision 1409 - seems to work fine.
Close it as fixed.

#3

Updated by Anonymous almost 11 years ago

Milestone 0.2 release deleted

#4

Updated by Anonymous over 10 years ago

  • Assignee deleted (Anonymous)
  • Category set to 2
#5

Updated by Sven Eckelmann over 4 years ago

  • Target version set to 0.2

Also available in: Atom PDF