Project

General

Profile

Bug #85

possible recursive deadlock in batman-adv-kernelland

Added by Anonymous about 13 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

=============================================
[ INFO: possible recursive locking detected ]
2.6.25.7 #36
---------------------------------------------
swapper/0 is trying to acquire lock:
(_xmit_ETHER){-+..}, at: [<c023d426>] +qdisc_run+0x94/0x184

but task is already holding lock:
(_xmit_ETHER){-+..}, at: [<c023d426>] +qdisc_run+0x94/0x184

other info that might help us debug this:
4 locks held by swapper/0:
#0: (rcu_read_lock){..--}, at: [<c0232aeb>] dev_queue_xmit+0xc5/0x272
#1: (_xmit_ETHER){-+..}, at: [<c023d426>] +qdisc_run+0x94/0x184
#2: (rcu_read_lock){..--}, at: [<c288964a>] interface_tx+0x61/0x231 [batman_adv_core]
#3: (rcu_read_lock){..--}, at: [<c0232aeb>] dev_queue_xmit+0xc5/0x272

stack backtrace:
Pid: 0, comm: swapper Not tainted 2.6.25.7 #36
[<c0136f6f>] +lock_acquire+0x7c7/0xaca
[<c01375f2>] lock_acquire+0x4e/0x6a
[<c023d426>] ? +qdisc_run+0x94/0x184
[<c029444b>] _spin_lock+0x23/0x32
[<c023d426>] ? +qdisc_run+0x94/0x184
[<c023d426>] +qdisc_run+0x94/0x184
[<c0232b65>] dev_queue_xmit+0x13f/0x272
[<c2887595>] send_raw_packet+0x121/0x32b [batman_adv_core]
[<c28896d9>] interface_tx+0xf0/0x231 [batman_adv_core]
[<c02307e1>] dev_hard_start_xmit+0x1e6/0x242
[<c023d436>] +qdisc_run+0xa4/0x184
[<c0232b65>] dev_queue_xmit+0x13f/0x272
[<c026d9a7>] arp_xmit+0x3d/0x42
[<c026e2db>] arp_send+0x32/0x37
[<c026eb90>] arp_solicit+0x1d0/0x1db
[<c0237fd4>] neigh_timer_handler+0x275/0x2bd
[<c0124ee2>] run_timer_softirq+0x102/0x15d
[<c0237d5f>] ? neigh_timer_handler+0x0/0x2bd
[<c0121c36>] +do_softirq+0x6d/0xea
[<c0121cec>] do_softirq+0x39/0x55
[<c0121dc7>] irq_exit+0x46/0x53
[<c010f20f>] smp_apic_timer_interrupt+0x6f/0x80
[<c0104947>] apic_timer_interrupt+0x33/0x38
[<c0102640>] ? default_idle+0x4a/0x77
[<c01025f6>] ? default_idle+0x0/0x77
[<c01025ce>] cpu_idle+0x70/0x98
[<c028dc4d>] rest_init+0x5d/0x5f =======================


Related issues

Is duplicate of batman-adv - Bug #89: warning: possible recursive deadlockClosed

Actions

History

#1

Updated by Anonymous about 13 years ago

  • Status changed from New to Closed
#2

Updated by Anonymous over 10 years ago

  • Assignee deleted (Anonymous)
  • Category set to 2
#3

Updated by Sven Eckelmann over 4 years ago

  • Is duplicate of Bug #89: warning: possible recursive deadlock added
#4

Updated by Sven Eckelmann over 4 years ago

  • Status changed from Closed to Rejected

Also available in: Atom PDF