Project

General

Profile

systemd v248 brings support for B.A.T.M.A.N. Advanced

Added by Annika Wickert 6 months ago

With the release of systemd v248, systemd-networkd now supports creation and management of B.A.T.M.A.N. Advanced interfaces.

The minimum required version of batman-adv to work with systemd-networkd is 2021.0.

An example .netdev file looks like the following:

[NetDev]
Name=bat0
Kind=batadv

[BatmanAdvanced]
GatewayMode=server
RoutingAlgorithm=batman-v
OriginatorIntervalSec=5

Thanks

For all the reviews and advices The initial idea
  • Andreas Rammhold
Sending in the patch

Comments