Project

General

Profile

Bug #186

3.14: Possible recursive lock with nc enabled

Added by Markus Pargmann over 7 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/18/2014
Due date:
% Done:

0%

Estimated time:

Description

I noticed a recursive lock stack dump when using batman with network coding on linux 3.14. I observed this bug multiple times within one day on multiple devices.

The device batman was running on is a ARM cortex-a9. (RIoT board with freescale i.MX6s)

I attached the stack dump. If you need any further information or someone to test, let me know.


Files

batman_recursive_lock (4.41 KB) batman_recursive_lock 3.14.3-recursive-lock Markus Pargmann, 05/18/2014 03:16 PM

Related issues

Is duplicate of batman-adv - Bug #178: possible recursive locking detected in ncRejected11/15/2013

Actions

History

#1

Updated by Marek Lindner almost 7 years ago

  • Status changed from New to Closed
  • Project changed from batctl to batmand

Duplicate of #178.

#2

Updated by Marek Lindner almost 7 years ago

  • Project changed from batmand to batman-adv
#3

Updated by Sven Eckelmann almost 5 years ago

  • Is duplicate of Bug #178: possible recursive locking detected in nc added
#4

Updated by Sven Eckelmann almost 5 years ago

  • Status changed from Closed to Rejected

Also available in: Atom PDF