Project

General

Profile

Feature #175

The IPv6 issue, any solutions?

Added by Tim V about 6 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
08/13/2013
Due date:
% Done:

0%


Description

Is there any way currently to have an batman adv mesh using ipv6?
I'm aware that the gateway packet interception system for dhcp has been extended to dhcpv6.
This means each client only gets ip addresses from the closest/best gateway.
However dhcpv6 does not handle routing data, it only assigns IP's.
The SLAAC system distributes all the routing data, and as it is un-managed, the client will have piles of different routes, and no way to choose. That was the original purpose of the gateway system to stop.

I saw the previous issue related to this, but it has not been used in 9 months. Is anyone working on a solution? If not I could mabey help.

Does the client defualt to using the gateway from the dhcp server it is using, or are all the routes treated equally? I don't have networking background.


Related issues

Duplicates batman-adv - Feature #159: gw_mode and router advertisement daemon for IPv6 Rejected 05/24/2012

History

#1 Updated by Antonio Quartulli almost 6 years ago

Hi Tim,

you are right, the GW feature works only with DHCP and DHCPv6. However it is only an optimisation.
You can safely set the GW mode to off and the rest will work as you expected: every node will receive everything like being connected to a normal Ethernet switch. No packet is alterated or filtered.

At the moment there is no plan about extending the GW feature to work with other IPv6 mechanisms.

Regards,

#2 Updated by Antonio Quartulli almost 6 years ago

  • Status changed from New to Closed

ticket closed because it is a duplicate of ticket #159

#3 Updated by Sven Eckelmann over 2 years ago

  • Duplicates Feature #159: gw_mode and router advertisement daemon for IPv6 added

#4 Updated by Sven Eckelmann over 2 years ago

  • Status changed from Closed to Rejected

Also available in: Atom PDF