Project

General

Profile

Bug #170

br-lan: received packet on bat0 with own address as source address

Added by Carlos Quijano about 8 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
05/06/2013
Due date:
% Done:

100%

Estimated time:

Description

I have many messages on my dmesg on gateway nodes:

br-lan: received packet on bat0 with own address as source address

Im using Openwrt, config attached ( gateways and repeaters ).

All nodes user the same batman-adv version:

[ 11.650000] batman_adv: B.A.T.M.A.N. advanced 2013.2.0 (compatibility version 14) loaded

root@OpenWrt:~# batctl -v
batctl 2013.2.0 [batman-adv: 2013.2.0]

Batman-adv config is attached too ( same for all nodes).


Files

repeater_wireless_config (1.17 KB) repeater_wireless_config Carlos Quijano, 05/06/2013 11:00 AM
gw_wireless_config (1.08 KB) gw_wireless_config Carlos Quijano, 05/06/2013 11:00 AM
repeater_network_config (624 Bytes) repeater_network_config Carlos Quijano, 05/06/2013 11:00 AM
gw_network_config (894 Bytes) gw_network_config Carlos Quijano, 05/06/2013 11:00 AM
batman-adv (261 Bytes) batman-adv Carlos Quijano, 05/06/2013 11:00 AM
666-make-DAT-drop-ARP-requests-targeting-loca.patch (1.41 KB) 666-make-DAT-drop-ARP-requests-targeting-loca.patch Antonio Quartulli, 05/08/2013 10:14 AM

Related issues

Related to batman-adv - Bug #409: DAT: received packet on bat0.20/eth0 with own address as source addressIn Progress04/22/2020

Actions

History

#1

Updated by Simon Wunderlich about 8 years ago

  • Assignee set to Simon Wunderlich

You have bat0 and eth0 bridge in the same bridge. This should not be a problem as we have bridge loop avoidance (bla) which should handle this case. I have a few questions to narrow down your case:

  • Do these messages still appear after 30 seconds of operation? BLA might take a moment to detect that all routers are on the same LAN. Make sure that the routers are connected when batman-adv is started. * Do you have bridge loop avoidance enabled? It appears to be in the configuration, but please check using "batctl bl" * Please print the output of "batctl claimtable", "batctl backbonetable", "batctl tg"
#2

Updated by Carlos Quijano about 8 years ago

The messages appear all time:
root@OpenWrt:~# uptime
14:33:07 up 2:17, load average: 0.10, 0.14, 0.14
root@OpenWrt:~# dmesg | tail
[ 6626.620000] br-lan: received packet on bat0 with own address as source address
[ 6627.620000] br-lan: received packet on bat0 with own address as source address
[ 6650.940000] br-lan: received packet on bat0 with own address as source address
[ 6651.930000] br-lan: received packet on bat0 with own address as source address
[ 6681.830000] br-lan: received packet on bat0 with own address as source address
bridge loop avoidance enabled is enable ( you can see at batman-adv file attached):
root@OpenWrt:~# batctl bl
enabled

Requested tables:

root@OpenWrt:~# batctl claimtable
Claims announced for the mesh bat0 (orig 00:27:22:23:1a:4e, group id 0xe144)
Client VID Originator [o] (CRC ) * e6:ec:38:be:94:a0 on -1 by 00:27:22:23:1a:4e [x] (0x3ef5) * 06:a7:22:f0:93:b4 on -1 by 00:27:22:23:1a:4e [x] (0x3ef5) * 06:a7:22:08:2f:ee on -1 by 00:27:22:23:1a:4e [x] (0x3ef5) * b8:27:eb:7f:18:60 on -1 by 00:27:22:23:1a:4e [x] (0x3ef5) * 06:c0:ca:5f:6b:54 on -1 by 00:27:22:23:1a:4e [x] (0x3ef5)
root@OpenWrt:~# batctl backbonetable
Backbones announced for the mesh bat0 (orig 00:27:22:23:1a:4e, group id 0xe144)
Originator VID last seen (CRC )
root@OpenWrt:~# batctl tg
Globally announced TT entries received via the mesh bat0
Client (TTVN) Originator (Curr TTVN) (CRC ) Flags * 06:a7:22:08:2f:ee ( 2) via 00:27:22:08:2f:ee ( 2) (0x3ad5) [...] * 6a:31:d6:c0:aa:db ( 2) via 00:c0:ca:5f:6b:54 ( 2) (0x3353) [...] * 2a:08:ed:38:c0:5b ( 3) via 00:27:22:f0:93:b4 ( 3) (0x4931) [...] * 06:a7:22:f0:93:b4 ( 3) via 00:27:22:f0:93:b4 ( 3) (0x4931) [...] * 06:c0:ca:5f:6b:54 ( 2) via 00:c0:ca:5f:6b:54 ( 2) (0x3353) [...] * fe:ae:99:7f:00:d2 ( 2) via f4:ec:38:be:94:a0 ( 2) (0x32e7) [...] * b8:27:eb:7f:18:60 ( 3) via 00:27:22:f0:93:b4 ( 3) (0x4931) [...] * e6:ec:38:be:94:a0 ( 2) via f4:ec:38:be:94:a0 ( 2) (0x32e7) [...] * ce:bf:f2:a8:ff:28 ( 2) via 00:27:22:08:2f:ee ( 2) (0x3ad5) [...]
root@OpenWrt:~#

Thank in advance.

#3

Updated by Carlos Quijano about 8 years ago

Sorry, pre tag
Requested tables:

root@OpenWrt:~# batctl claimtable
Claims announced for the mesh bat0 (orig 00:27:22:23:1a:4e, group id 0xe144)
   Client               VID      Originator        [o] (CRC   )
 * e6:ec:38:be:94:a0 on    -1 by 00:27:22:23:1a:4e [x] (0x3ef5)
 * 06:a7:22:f0:93:b4 on    -1 by 00:27:22:23:1a:4e [x] (0x3ef5)
 * 06:a7:22:08:2f:ee on    -1 by 00:27:22:23:1a:4e [x] (0x3ef5)
 * b8:27:eb:7f:18:60 on    -1 by 00:27:22:23:1a:4e [x] (0x3ef5)
 * 06:c0:ca:5f:6b:54 on    -1 by 00:27:22:23:1a:4e [x] (0x3ef5)
root@OpenWrt:~# batctl backbonetable
Backbones announced for the mesh bat0 (orig 00:27:22:23:1a:4e, group id 0xe144)
   Originator           VID   last seen (CRC   )
root@OpenWrt:~# batctl tg
Globally announced TT entries received via the mesh bat0
       Client        (TTVN)       Originator      (Curr TTVN) (CRC   ) Flags
 * 06:a7:22:08:2f:ee  (  2) via 00:27:22:08:2f:ee     (  2)   (0x3ad5) [...]
 * 6a:31:d6:c0:aa:db  (  2) via 00:c0:ca:5f:6b:54     (  2)   (0x3353) [...]
 * 2a:08:ed:38:c0:5b  (  3) via 00:27:22:f0:93:b4     (  3)   (0x4931) [...]
 * 06:a7:22:f0:93:b4  (  3) via 00:27:22:f0:93:b4     (  3)   (0x4931) [...]
 * 06:c0:ca:5f:6b:54  (  2) via 00:c0:ca:5f:6b:54     (  2)   (0x3353) [...]
 * fe:ae:99:7f:00:d2  (  2) via f4:ec:38:be:94:a0     (  2)   (0x32e7) [...]
 * b8:27:eb:7f:18:60  (  3) via 00:27:22:f0:93:b4     (  3)   (0x4931) [...]
 * e6:ec:38:be:94:a0  (  2) via f4:ec:38:be:94:a0     (  2)   (0x32e7) [...]
 * ce:bf:f2:a8:ff:28  (  2) via 00:27:22:08:2f:ee     (  2)   (0x3ad5) [...]
root@OpenWrt:~# 

#4

Updated by Simon Wunderlich about 8 years ago

Thanks for the tables. What is weird is that the backbonetable is empty, although it should list the other devices running batman-adv.

How are the devices interconnected via Ethernet? Are you using a simple layer 2 switch or some kind of "managed switch", firewall, etc? Does the problem go away if you remove one of the devices from the ethernet (i.e. remove the cable)?

#5

Updated by Carlos Quijano about 8 years ago

Is normal that backbonetable is empty, i have no loops , or wire connections on my network.

The network more or less is like:

Wire Client---Node[Repeater]----Mesh---Node[Gw]--Wire[WAN]---Cable Modem

Wire-WAN is NOT Bridged, but Wire Client is Bridge with AP's and BAT0 ( See config attached for details).

I have no Wire connected that could be remove, only wire client, and if i disconnect , it's change nothing.

#6

Updated by Simon Wunderlich about 8 years ago

Hmm, I don't see where the problem is, guess we have to reduce it further. I'll provide some suggestion, feel free to try out own ideas to find out what exactly triggers these messages:

  • according to your global table you have more than just two nodes in your network. Can you try turning some off so that you only have two or even just one and see if the problem is still present? * if you have no wired connection/loops, can you try disabling bridge loop avoidance? (Although this alone should not create these messages) * can you check whether the mac addresses you set in your config file are actually applied?

Thanks

#7

Updated by Carlos Quijano about 8 years ago

Thank you very much for your quick answer.

I will try the first and second point. I think this is related with number of nodes ( 3 or more causes this error).

With the 3rd point, all mac are direferent in all interfaces and all nodes (there are not 2 macs equal). You can check it on attaked network config, ifconfig show that are setted correcly.

root@OpenWrt:~# batctl o
[B.A.T.M.A.N. adv 2013.2.0, MainIF/MAC: mesh_0_g/00:27:22:23:1a:4e (bat0)]
  Originator      last-seen (#/255)           Nexthop [outgoingIF]:   Potential nexthops ...
00:27:22:f0:93:b4    0.590s   (255) 00:27:22:f0:93:b4 [  mesh_0_g]: 00:27:22:f0:93:b4 (255)

root@OpenWrt:~# uci show network
network.globals=globals
network.globals.ula_prefix=fda8:d82d:6b5f::/48
network.@switch[0]=switch
network.@switch[0].name=switch0
network.@switch[0].reset=1
network.@switch[0].enable_vlan=0
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device=switch0
network.@switch_vlan[0].vlan=1
network.@switch_vlan[0].ports=0 1 2 3 4
network.loopback=interface
network.loopback.ifname=lo
network.loopback.proto=static
network.loopback.ipaddr=127.0.0.1
network.loopback.netmask=255.0.0.0
network.wan=interface
network.wan.proto=dhcp
network.wan.ifname=eth1
network.wan.macaddr=16:27:22:23:1A:4E
network.lan=interface
network.lan.ifname=eth0 bat0
network.lan.type=bridge
network.lan.stp=0
network.lan.macaddr=06:A7:22:23:1A:4E
network.lan.proto=static
network.lan.ipaddr=10.35.26.78
network.lan.netmask=255.0.0.0
network.lan.mtu=1600
network.eth0=interface
network.eth0.proto=none
network.eth0.ifname=eth0
network.eth0.macaddr=06:27:22:23:1A:4E
network.mesh=interface
network.mesh.proto=batadv
network.mesh.mtu=1600
network.mesh.mesh=bat0

bat0      Link encap:Ethernet  HWaddr 72:B3:69:15:DA:3D  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:73839 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31993 errors:0 dropped:1094 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:13459798 (12.8 MiB)  TX bytes:6202042 (5.9 MiB)

br-lan    Link encap:Ethernet  HWaddr 06:A7:22:23:1A:4E  
          inet addr:10.35.26.78  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:80800 errors:0 dropped:77 overruns:0 frame:0
          TX packets:38235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:13580009 (12.9 MiB)  TX bytes:9007792 (8.5 MiB)

client_0_priv Link encap:Ethernet  HWaddr 0A:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2696 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45000 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:575915 (562.4 KiB)  TX bytes:5903679 (5.6 MiB)

client_0_pub Link encap:Ethernet  HWaddr 1A:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44279 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:5438617 (5.1 MiB)

eth0      Link encap:Ethernet  HWaddr 06:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3457 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47806 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:642044 (626.9 KiB)  TX bytes:6911750 (6.5 MiB)
          Interrupt:5 

eth1      Link encap:Ethernet  HWaddr 16:27:22:23:1A:4E  
          inet addr:212.225.155.130  Bcast:212.225.155.255  Mask:255.255.252.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:924755 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53996 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:5 
          RX bytes:101433186 (96.7 MiB)  TX bytes:19488620 (18.5 MiB)
          Interrupt:4 

ifb0      Link encap:Ethernet  HWaddr B2:8F:38:68:A8:FF  
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:165612 errors:0 dropped:0 overruns:0 frame:0
          TX packets:165612 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:5 
          RX bytes:55723833 (53.1 MiB)  TX bytes:55723833 (53.1 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4156 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:326809 (319.1 KiB)  TX bytes:326809 (319.1 KiB)

mesh_0_g  Link encap:Ethernet  HWaddr 00:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1600  Metric:1
          RX packets:508182 errors:0 dropped:63 overruns:0 frame:0
          TX packets:176964 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:55702705 (53.1 MiB)  TX bytes:23587296 (22.4 MiB)

#8

Updated by Carlos Quijano about 8 years ago

I have updated to batman-adv-dev:

[   14.770000] batman_adv: B.A.T.M.A.N. advanced 90725dd (compatibility version 14) loaded

Same problem[3 Nodes 1 Gateway. bridge_loop_avoidance enabled]:

[  107.110000] device bat0 entered promiscuous mode
[  107.110000] br-lan: port 4(bat0) entered forwarding state
[  107.120000] br-lan: port 4(bat0) entered forwarding state
[  107.370000] batman_adv: bat0: ap_isolation: Changing from: disabled to: enabled
[  107.390000] batman_adv: bat0: bridge_loop_avoidance: Changing from: disabled to: enabled
[  107.410000] batman_adv: bat0: Changing gateway bandwidth from: '41' to: '48' (propagating: 4MBit/512KBit)
[  107.430000] batman_adv: bat0: Changing gw mode from: off to: server
[  109.120000] br-lan: port 4(bat0) entered forwarding state
[  972.230000] br-lan: received packet on bat0 with own address as source address
[  973.230000] br-lan: received packet on bat0 with own address as source address
[  974.240000] br-lan: received packet on bat0 with own address as source address
[  975.240000] br-lan: received packet on bat0 with own address as source address
[  976.250000] br-lan: received packet on bat0 with own address as source address
[  977.250000] br-lan: received packet on bat0 with own address as source address
[  978.270000] br-lan: received packet on bat0 with own address as source address
[  979.270000] br-lan: received packet on bat0 with own address as source address
[  980.270000] br-lan: received packet on bat0 with own address as source address
...
[ 1217.980000] br-lan: received packet on bat0 with own address as source address
[ 1218.990000] br-lan: received packet on bat0 with own address as source address

#9

Updated by Carlos Quijano about 8 years ago

Tested with 2 nodes (1 repeater 1 gw ):
Message still appears:

[  109.840000] br-lan: port 4(bat0) entered learning state
[  111.840000] br-lan: topology change detected, propagating
[  111.840000] br-lan: port 4(bat0) entered forwarding state
[  116.250000] br-lan: received packet on bat0 with own address as source address

bridge_loop_avoidance is disable in both nodes.

But with 2 nodes is very dificult to replicate the problem, i think this is related with number of nodes in mesh.
I will try again with more nodes.

#10

Updated by Simon Wunderlich about 8 years ago

Hm, does the problem even appear with only one node?

Could you try to "catch" the offending packet? E.g. using tcpdump or batctl td?

Are the bat0 mac addresses different on all nodes?

#11

Updated by Carlos Quijano about 8 years ago

Yes all mac on bat0 ifaces, in all nodes are different.

Im trying to catch the packet with tcpdump.

One curious thing is when error occurs, is every second:

[ 2988.140000] br-lan: received packet on bat0 with own address as source address
[ 3014.010000] net_ratelimit: 144 callbacks suppressed
[ 3014.010000] br-lan: received packet on bat0 with own address as source address
[ 3015.010000] br-lan: received packet on bat0 with own address as source address
[ 3016.020000] br-lan: received packet on bat0 with own address as source address
[ 3031.890000] br-lan: received packet on bat0 with own address as source address
[ 3032.890000] br-lan: received packet on bat0 with own address as source address
[ 3033.890000] br-lan: received packet on bat0 with own address as source address
[ 3034.900000] br-lan: received packet on bat0 with own address as source address
[ 3035.910000] br-lan: received packet on bat0 with own address as source address
[ 3036.910000] br-lan: received packet on bat0 with own address as source address
[ 3037.920000] br-lan: received packet on bat0 with own address as source address
[ 3038.920000] br-lan: received packet on bat0 with own address as source address
[ 3039.930000] br-lan: received packet on bat0 with own address as source address
[ 3040.930000] br-lan: received packet on bat0 with own address as source address
[ 3041.940000] br-lan: received packet on bat0 with own address as source address
[ 3042.940000] br-lan: received packet on bat0 with own address as source address
[ 3043.960000] br-lan: received packet on bat0 with own address as source address
[ 3044.950000] br-lan: received packet on bat0 with own address as source address
[ 3076.080000] br-lan: received packet on bat0 with own address as source address
[ 3077.920000] br-lan: received packet on bat0 with own address as source address
[ 3078.920000] br-lan: received packet on bat0 with own address as source address
[ 3079.930000] br-lan: received packet on bat0 with own address as source address
[ 3080.940000] br-lan: received packet on bat0 with own address as source address
[ 3081.940000] br-lan: received packet on bat0 with own address as source address
[ 3082.940000] br-lan: received packet on bat0 with own address as source address
[ 3083.950000] br-lan: received packet on bat0 with own address as source address
[ 3084.950000] br-lan: received packet on bat0 with own address as source address
[ 3085.960000] br-lan: received packet on bat0 with own address as source address
[ 3086.970000] br-lan: received packet on bat0 with own address as source address
[ 3087.970000] br-lan: received packet on bat0 with own address as source address
[ 3088.980000] br-lan: received packet on bat0 with own address as source address
[ 3090.010000] br-lan: received packet on bat0 with own address as source address
[ 3090.990000] br-lan: received packet on bat0 with own address as source address
[ 3092.030000] br-lan: received packet on bat0 with own address as source address
[ 3093.860000] br-lan: received packet on bat0 with own address as source address
[ 3094.870000] br-lan: received packet on bat0 with own address as source address
[ 3095.870000] br-lan: received packet on bat0 with own address as source address
[ 3097.070000] br-lan: received packet on bat0 with own address as source address
[ 3098.070000] br-lan: received packet on bat0 with own address as source address
[ 3099.080000] br-lan: received packet on bat0 with own address as source address
[ 3100.260000] br-lan: received packet on bat0 with own address as source address
[ 3101.260000] br-lan: received packet on bat0 with own address as source address
[ 3102.270000] br-lan: received packet on bat0 with own address as source address

How often send batman control message over the mesh? every second ?

#12

Updated by Simon Wunderlich about 8 years ago

this can be configured using the "originator interval", but basically yes, every second. It is not going via the "soft interface" bat0, though.

#13

Updated by Carlos Quijano about 8 years ago

Ok i think that i found it, i think there is a problem with ARP.

tcpdump -e -n -v -XX -i br-lan not ip
....
17:31:58.538279 06:a7:22:23:1a:4e > 90:4c:e5:82:27:6d, ethertype ARP (0x0806), length 42: Ethernet (len 6), IPv4 (len 4), Reply 10.35.26.78 is-at 06:a7:22:23:1a:4e, length 28
        0x0000:  904c e582 276d 06a7 2223 1a4e 0806 0001  .L..'m.."#.N....
        0x0010:  0800 0604 0002 06a7 2223 1a4e 0a23 1a4e  ........"#.N.#.N
        0x0020:  904c e582 276d 0ac3 2b2e                 .L..'m..+.
17:31:58.545855 06:a7:22:23:1a:4e > 90:4c:e5:82:27:6d, ethertype ARP (0x0806), length 42: Ethernet (len 6), IPv4 (len 4), Reply 10.35.26.78 is-at 06:a7:22:23:1a:4e, length 28
        0x0000:  904c e582 276d 06a7 2223 1a4e 0806 0001  .L..'m.."#.N....
        0x0010:  0800 0604 0002 06a7 2223 1a4e 0a23 1a4e  ........"#.N.#.N
        0x0020:  904c e582 276d 0ac3 2b2e                 .L..'m..+.
....

root@OpenWrt:~# ifconfig |grep HWaddr
bat0      Link encap:Ethernet  HWaddr 1E:2E:16:89:01:C2  
br-lan    Link encap:Ethernet  HWaddr 06:A7:22:23:1A:4E  
client_0_priv Link encap:Ethernet  HWaddr 0A:27:22:23:1A:4E  
client_0_pub Link encap:Ethernet  HWaddr 1A:27:22:23:1A:4E  
eth0      Link encap:Ethernet  HWaddr 06:27:22:23:1A:4E  
eth1      Link encap:Ethernet  HWaddr 16:27:22:23:1A:4E  
ifb0      Link encap:Ethernet  HWaddr 96:6F:B6:A0:8D:8E  
mesh_0_g  Link encap:Ethernet  HWaddr 00:27:22:23:1A:4E  

I have distributed_arp_table enabled in all nodes:
root@OpenWrt:~# batctl dat
enabled
root@OpenWrt:~# batctl dc
Distributed ARP Table (bat0):
          IPv4             MAC           last-seen
 *    10.75.247.85 b8:27:eb:7f:18:60      4:32
 *   10.54.149.196 b4:07:f9:38:4f:55      4:36
 *     10.8.47.238 06:a7:22:08:2f:ee      4:34
 *     10.35.26.78 06:a7:22:23:1a:4e      0:12
 *    10.195.43.46 90:4c:e5:82:27:6d      0:06
 *    10.95.107.84 06:c0:ca:5f:6b:54      2:43
 *  10.190.148.160 e6:ec:38:be:94:a0      1:13

The arp request must not be reply though mesh to the origin.
Is this a bug or im doing something wrong?

#14

Updated by Simon Wunderlich about 8 years ago

Hm, not sure, but can you try turning off dat to make sure this is the component creating the problem?

Also, for completeness, maybe you can post the output of "batctl if" and "brctl show".

Thanks

#15

Updated by Carlos Quijano about 8 years ago

Sure:

root@OpenWrt:~# batctl if
mesh_0_g: active
root@OpenWrt:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.06a722231a4e       yes             eth0
                                                        client_0_pub
                                                        client_0_priv
                                                        bat0
root@OpenWrt:~# ifconfig 
bat0      Link encap:Ethernet  HWaddr 1E:2E:16:89:01:C2  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:413661 errors:0 dropped:0 overruns:0 frame:0
          TX packets:403889 errors:0 dropped:1536 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:261126237 (249.0 MiB)  TX bytes:322547555 (307.6 MiB)

br-lan    Link encap:Ethernet  HWaddr 06:A7:22:23:1A:4E  
          inet addr:10.35.26.78  Bcast:10.255.255.255  Mask:255.0.0.0
          inet6 addr: fe80::4a7:22ff:fe23:1a4e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:426427 errors:0 dropped:0 overruns:0 frame:0
          TX packets:407900 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:256862461 (244.9 MiB)  TX bytes:326211780 (311.0 MiB)

client_0_priv Link encap:Ethernet  HWaddr 0A:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2339 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4067 (3.9 KiB)  TX bytes:509095 (497.1 KiB)

client_0_pub Link encap:Ethernet  HWaddr 1A:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:474 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2787 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:32033 (31.2 KiB)  TX bytes:544569 (531.8 KiB)

eth0      Link encap:Ethernet  HWaddr 06:27:22:23:1A:4E  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19367 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23544 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3714151 (3.5 MiB)  TX bytes:9107107 (8.6 MiB)
          Interrupt:5 

eth1      Link encap:Ethernet  HWaddr 16:27:22:23:1A:4E  
          inet addr:212.225.155.130  Bcast:212.225.155.255  Mask:255.255.252.0
          inet6 addr: fe80::1427:22ff:fe23:1a4e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:549285 errors:0 dropped:28 overruns:0 frame:0
          TX packets:358203 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:5 
          RX bytes:349575481 (333.3 MiB)  TX bytes:140710845 (134.1 MiB)
          Interrupt:4 

ifb0      Link encap:Ethernet  HWaddr 96:6F:B6:A0:8D:8E  
          inet6 addr: fe80::946f:b6ff:fea0:8d8e/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:480615 errors:0 dropped:725 overruns:0 frame:0
          TX packets:479890 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:5 
          RX bytes:344405883 (328.4 MiB)  TX bytes:344029097 (328.0 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:711 errors:0 dropped:0 overruns:0 frame:0
          TX packets:711 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:55387 (54.0 KiB)  TX bytes:55387 (54.0 KiB)

mesh_0_g  Link encap:Ethernet  HWaddr 00:27:22:23:1A:4E  
          inet6 addr: fe80::227:22ff:fe23:1a4e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1600  Metric:1
          RX packets:466223 errors:0 dropped:109 overruns:0 frame:0
          TX packets:419561 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:276579585 (263.7 MiB)  TX bytes:342281457 (326.4 MiB)

root@OpenWrt:~# 

I will try without distributed_arp_table.

#16

Updated by Antonio Quartulli about 8 years ago

Hi Carlos,

Carlos Quijano wrote:

Ok i think that i found it, i think there is a problem with ARP.

The packets you shown were captured less then one second after the other, right? while you said the message is appearing once every second..maybe the ARP packets is not really the culprit.
Also why filtering "not ip"? maybe it is some IP packet that is generating the message, no?

Howver, I first wait for you to verify if the problem is there after disabling DAT.

bye

#17

Updated by Carlos Quijano about 8 years ago

Hi Antonio.
Im filtering with no ip, because there are too many pakages, i dont think the problems came from a ip packages.
The kernel warning, i think, is caused by the second package, so, dont mind the time between packages, the importan thing is that the package is replied to the origin.

i will keep you informed, thank you.

#18

Updated by Carlos Quijano about 8 years ago

Hi Antonio.
Im filtering with no ip, because there are too many pakages, i dont think the problems came from a ip packages.
The kernel warning, i think, is caused by the second package, so, dont mind the time between packages, the importan thing is that the package is replied to the origin.

i will keep you informed, thank you.

#19

Updated by Carlos Quijano about 8 years ago

I can confirm it, with distributed_arp_table turned off, Kernel warnings disappears.

Thank you all.

#20

Updated by Antonio Quartulli about 8 years ago

  • % Done changed from 0 to 10
  • Assignee changed from Simon Wunderlich to Antonio Quartulli
#21

Updated by Antonio Quartulli about 8 years ago

  • File 666-make-DAT-drop-ARP-requests-targeting-loca.patch added

Carlos Quijano wrote:

I can confirm it, with distributed_arp_table turned off, Kernel warnings disappears.

Thank you all.

I think I found the problem.
Would you mind testing this patch?

Thanks

#22

Updated by Antonio Quartulli about 8 years ago

  • File deleted (666-make-DAT-drop-ARP-requests-targeting-loca.patch)
#24

Updated by Carlos Quijano about 8 years ago

Dont worry. I will try, just gime some time to be sure that its works.
i will keep you informed.

#25

Updated by Carlos Quijano about 8 years ago

After 24h of test, the patch is working correctly, no more kernel error has appeared on my dmesg.

Thank you all.

#26

Updated by Antonio Quartulli about 8 years ago

Carlos Quijano wrote:

After 24h of test, the patch is working correctly, no more kernel error has appeared on my dmesg.

Thank you all.

Thank you for testing Carlos.
I will send the patch to the mailing list with you as Reported-by and Tested-by.

Thanks a lot again!

#27

Updated by Antonio Quartulli about 8 years ago

  • % Done changed from 10 to 100
  • Status changed from New to Resolved
#28

Updated by Antonio Quartulli over 7 years ago

  • Status changed from Resolved to Closed
#29

Updated by Sven Eckelmann over 4 years ago

  • Target version set to 2013.3.0
#30

Updated by Sven Eckelmann about 1 year ago

  • Related to Bug #409: DAT: received packet on bat0.20/eth0 with own address as source address added

Also available in: Atom PDF