Project

General

Profile

Bug #154

Mesh link work abnormalities

Added by Anonymous almost 10 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Target version:
Start date:
10/20/2011
Due date:
% Done:

0%

Estimated time:

Description

Test environment:
1. Three set AP separately according to the configuration Settings.

2. AP1, AP2, AP3 respectively through the wireless connections, through the physical isolation, AP1 with AP2 only to communication, AP3 also can and AP2 communication, AP1 with AP3 need through the AP2 to communication, PC1 through the cable connection to the eht0 AP1.

Test method:
1. First of all AP are powerd on, PC1 ping connection at this time AP1,AP2,AP3 test is normal.

2.cut off the power of AP1 and repowered it,then PC1 ping test AP1,AP2 are normally tested,AP3 cannot communication.

3.Through the Telnet to log on to AP2, through the AP2 ping AP3 is normal. But the PC and AP3 have been unable to communication, unless all the power to restart


Files

1.jpg (28.6 KB) 1.jpg Environmental schemes Anonymous, 10/20/2011 07:25 AM
batman.doc (32 KB) batman.doc Anonymous, 10/21/2011 05:35 AM
0001-batman-adv-unify-hash_entry-field-position-in-tt_loc.patch (1.55 KB) 0001-batman-adv-unify-hash_entry-field-position-in-tt_loc.patch Antonio Quartulli, 10/23/2011 09:53 PM

History

#1

Updated by Anonymous almost 10 years ago

I update to the latest version 2011.3.1

#2

Updated by Anonymous almost 10 years ago

li langfeng wrote:

I update to the latest version 2011.3.1

Does it mean that this also happens with 2011.3.1 or that this is fixed with 2011.3.1?

#3

Updated by Anonymous almost 10 years ago

Sven Eckelmann wrote:

li langfeng wrote:

I update to the latest version 2011.3.1

Does it mean that this also happens with 2011.3.1 or that this is fixed with 2011.3.1?

yes! 2011.3.1 The same is true!

#4

Updated by Antonio Quartulli almost 10 years ago

Hello, is the debug ON? to funther investigate the problem we would need some nice output from the nodes in order to understand what is going on.

First of all what does "unstable communication" mean? PC1 ping to AP3 works for a bunch of seconds then stops and then works again?

#5

Updated by Simon Wunderlich almost 10 years ago

Can you exclude problems on the WiFi layer? You can check this by:

  • have a look in "batctl o" if all nodes are in the table * assign an IP address on ath0 (e.g. 192.168.2.1-3), and try to ping this one respectively.
#6

Updated by Anonymous almost 10 years ago

Simon Wunderlich wrote:

Can you exclude problems on the WiFi layer? You can check this by:

  • have a look in "batctl o" if all nodes are in the table
  • assign an IP address on ath0 (e.g. 192.168.2.1-3), and try to ping this one respectively.

I did not open debug, I should how to provide the more detailed information to you.
All AP first open open the power supply, PC1 to AP1,AP2,AP3 are normal, when we AP1 people will shut off the power to turn on the power, PC1 can only to AP1,AP2, completely unable to AP3 (not is not stable, it is completely unable to connect), the problem can be repeated every time.

#7

Updated by Antonio Quartulli almost 10 years ago

li langfeng wrote:

I did not open debug, I should how to provide the more detailed information to you.

Please, can you provide us the output of "batctl o" "batctl tg" and "batctl tl" either before turning off AP1 and after?

All AP first open open the power supply, PC1 to AP1,AP2,AP3 are normal, when we AP1 people will shut off the power to turn on the power, PC1 can only to AP1,AP2, completely unable to AP3 (not is not stable, it is completely unable to connect), the problem can be repeated every time.

Ok, thanks for the detail

#8

Updated by Antonio Quartulli almost 10 years ago

Another question: What devices are those? (Please tell us the full name of the devices)

#9

Updated by Anonymous almost 10 years ago

AP1 ping to AP3 not connected,AP1 brtctl tr to AP3 connection to normal

#10

Updated by Anonymous almost 10 years ago

Antonio Quartulli wrote:

Another question: What devices are those? (Please tell us the full name of the devices)

AP:AR730+AR5414,openwrt backfire 10.03.1-rc6,r28443+madwifi(ahdemo)

#11

Updated by Anonymous almost 10 years ago

li langfeng wrote:

Antonio Quartulli wrote:

Another question: What devices are those? (Please tell us the full name of the devices)

AP:AR730+AR5414,openwrt backfire 10.03.1-rc6,r28443+madwifi(ahdemo)

sorry!
AR730=AR7130

#12

Updated by Antonio Quartulli almost 10 years ago

Thank you. But, please, can you also provide the output of "batctl o", "batctl tg" and "batctl tl" either before and after the reboot of AP1?

#13

Updated by Anonymous almost 10 years ago

Antonio Quartulli wrote:

Thank you. But, please, can you also provide the output of "batctl o", "batctl tg" and "batctl tl" either before and after the reboot of AP1?

The attached file for green coating is after the reboot information,In the global MAC address table can be found in the missing part

#14

Updated by Antonio Quartulli almost 10 years ago

  • File 0001-batman-adv-print-the-value-in-the-tt_global_entry-co.patch added

Hello, sorry for the delay. Your bug seems to be related to a bug we found this weekend. I'm attaching a patch which should help in this way. Can you please test it and tell us if it solves or not?

#15

Updated by Antonio Quartulli almost 10 years ago

  • File deleted (0001-batman-adv-print-the-value-in-the-tt_global_entry-co.patch)
#17

Updated by Anonymous over 9 years ago

I'm sorry, these days have gone out, I to download the latest source code, and the patch, this problem is gone, I found that the direct through from 2011.3.0 openwrt update to 2011.3.1 some file was not renewed.

#18

Updated by Simon Wunderlich over 9 years ago

  • Status changed from New to Resolved

So the bug is gone? I'll mark the bug as resolved then.

Thanks for reporting.

#19

Updated by Simon Wunderlich over 9 years ago

  • Status changed from Resolved to Closed
#20

Updated by Sven Eckelmann over 4 years ago

  • Target version set to 2012.0.0

Also available in: Atom PDF