Project

General

Profile

Bug #150

Bug in batctl cli: gw_mode

Added by Hendrik Fabelje over 10 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Target version:
Start date:
05/27/2011
Due date:
% Done:

100%

Estimated time:

Description

batctl gw_mode server [bandwith] leads to an error in the cli:

  1. batctl gw_mode server 100mbit/100mbit
    Error - the supplied argument is invalid: server
    The following values are allowed: * off * client * server

The values seem to be correctly set, however:

batctl gwl
Gateway (#/255) Nexthop [outgoingIF]: gw_class ... [B.A.T.M.A.N. adv next, MainIF/MAC: wlan0/00:24:01:XX:XX:XX (bat0)]
00:1b:63:XX:XX:XX (191) 00:c0:ca:XX:XX:XX [ wlan0]: 215 - 96MBit/96MBit

History

#1

Updated by Marek Lindner over 10 years ago

Thanks for the report! This bug has been already fixed. See the commit: https://git.open-mesh.org/?p=batctl.git;a=commit;h=eee3fc647349f8a0d2b671eed2f0e7375ac113d4

What batman-adv/batctl version are you using ? I believe the fix was part of the 2011.1.0 release.

#2

Updated by Anonymous over 10 years ago

Yes, it is part of v2011.1.0

$ git tag --contains eee3fc647349f8a0d2b671eed2f0e7375ac113d4
v2011.1.0

And this was not a bug in batman-adv, but in batctl. I'll move it to the right project

#3

Updated by Anonymous over 10 years ago

  • Project changed from batman-adv to batctl
#4

Updated by Anonymous over 10 years ago

  • % Done changed from 0 to 90
  • Status changed from New to Feedback
#5

Updated by Marek Lindner over 10 years ago

  • % Done changed from 90 to 100
  • Status changed from Feedback to Resolved

I think we can consider this bug fixed as the bug reporter did not get back to us.

#6

Updated by Marek Lindner over 10 years ago

  • Status changed from Resolved to Closed
#7

Updated by Sven Eckelmann over 4 years ago

  • Target version set to 2011.1.0

Also available in: Atom PDF